Meteor: support of version 1.0.5

Today, the Meteor team is releasing Meteor 1.0.5, this release focused on the upgrade of the Facebook connection package. Facebook is dropping the support for the 1.0 API the 30th April 2015 and is automatically migrating all the apps to the 2.0 branch of their API. To prevent any issue, Meteor is upgrading to the Facebook API 2.2.

image

Edit: We are currently supporting 1.1.1+, don’t worry if this article focuses on 1.0.5

If your are using the package accounts-facebook, you may need to upgrade your aplication. Please refer to https://github.com/meteor/meteor/wiki/Facebook-Graph-API-Upgrade to learn which processes are changing and how to handle them.

If you’re not using accounts-facebook this upgrade won’t affect your application.

Upgrade procedure

$ meteor update --release 1.0.5

# Ensure your app is working great in development and make the required
# modifications if necessary.
# Then:

$ git add .meteor/.finished-upgraders
$ git add .meteor/release
$ git add .meteor/versions
$ git commit -m "Update to meteor 1.0.5"
$ git push scalingo master

That’s it, there is nothing special to do, your application has been upgraded.

What are you waiting to try Scalingo?
30 days free trial. No credit card required. Deploy now, scale later.